arm_linux Cross Compiler Development Environment - gcc 4.8.2

1. Environment linux 16.04 2. Required source files  binutils-2.23.1.tar.bz2  glibc-2.18.tar.gz  gcc-4.8.2.tar.bz2  gmp-5.1.3.tar.bz2  mpfr-3.1.2.tar.bz2  mpc-1.0.1.tar.gz  linux-2.6.34.14.tar.bz2 3. Setting environmental variables export SRCDIR=~/workbench/gcc-4.8.2/xtools/src export BUILD ...

Posted on Mon, 12 Aug 2019 02:56:35 -0700 by Lillefix

Oracle Silent Installation 11gr2 has been verified and can be installed directly

Operating System and Oracle Versionlinux version: SUSE Linux Enterprise Server 11 (x86_64)Oracle version: Release 11.2.0.3.0  1. Check whether the dependency packages are installed successfully. If the installation is not successful, please install it.rpm -q binutils compat-libstdc++-33 elfutils-libelf elfutils-libelf-devel gcc gcc-c++ gli ...

Posted on Sat, 06 Jul 2019 19:55:35 -0700 by LuckyLucy

CentOS 7.2 system silently installs Oracle 11g2

1 Install centos7 System Environment (2 Core 2G40G Disk) Minimize installation by using CentOS 7.2 system, i.e. CentOS-7-x86_64-DVD-1511.iso image. After installation, adjust network settings IP, close firewall and selinux  vi /etc/sysconfig/network-scripts/ifcfg-eno16777736 ##Configuration network ##Restart network   systemctl restart networ ...

Posted on Mon, 25 Mar 2019 01:15:28 -0700 by patricklcam

Linux Memory Management: mmap Details

mmap system call mmap system call mmap maps a file or other object into memory. Files are mapped to multiple pages. If the size of the file is not the sum of all pages, the unused space of the last page will be cleared. munmap performs the opposite operation, deleting the object mapping for a specific address area. When using mmap to map ...

Posted on Thu, 21 Mar 2019 17:27:53 -0700 by nikkio3000

oracle database 19c install on LINUX 6.X

Officials can also install more than 6.4 in 18C, but the exadata of 19c now appears suddenly 7.4 (official requirement). Can 6.X still be installed? After testing, the following is the most feasible way. There are other better ways to welcome messages. (The following is the final version of ORACLE's 19c for linux version, which is purely a per ...

Posted on Wed, 27 Feb 2019 06:15:22 -0800 by inferium

Solve the problem of too low versions of/usr/lib64/libstdc++.so.6 and/lib64/libc.so.6

After compiling MySQL 5.7.14 in CentOS 7.0, MySQL is initialized in CentOS 6.5 and executed: /usr/local/mysql/bin/mysqld --version The following problems arise: ./bin/mysqld: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by ./bin/mysqld) ./bin/mysqld: /lib64/libc.so.6: version `GLIBC_2.14' not found (re ...

Posted on Sun, 10 Feb 2019 23:15:17 -0800 by webmasternovis