How to configure Huawei ISIS? Theory + practice, can follow!

Article directory

Preface

IS-IS and OSPF are both link state routing protocols. Now operators generally use IS-IS protocol to work

1: What is is IS-IS?

1.1: Overview

  • IS-IS (Intermediate system to intermediate system) is a kind of Internal gateway protocol It's telecommunications. Operator One of the commonly used internal Gateway Protocols
  • As OSPF, IS-IS is a link state routing protocol. It uses SPF algorithm, Hello packet to establish neighbor relationship, LSP to exchange link state information, and adopts layered design
  • For more definitions, please go directly to Baidu Encyclopedia

1.2: what are the routing types and functions of Huawei IS-IS?

  • Two router levels, L1 and L2
    • L1 is responsible for propagating link status information in the same area (similar to class 1 and class 2 in OSPF)
    • L2 is responsible for transmitting link status information to each other in different areas (similar to OSPF class 3)
  • Three router functions: L1, L2 and L1-2
    • L1 can obtain the path information in the area,
    • L2 can obtain path information between regions
    • L1-2: it can obtain paths within and between regions at the same time
  • The path connecting L2 router and L1/L2 router will form backbone area
  • IS-IS measures
    • The default measurement value of the interface is 10, which can be modified

1.3: establishment of neighbor relationship

  • In the same area
    • L1 can establish neighbor relationship with L1 and L1-2, but cannot establish neighbor relationship with L2
    • L2 can establish neighbor relationship with L2 and L1-2
    • L1-2 can establish neighbor relationship with L1 and L2
  • In different areas
    • L1 cannot establish neighbor relationship with other routes
    • L2 can establish neighbor relationship with other routes, except L1
    • L1-2 can establish neighbor relationship with other routes, except L1

1.4: NSAP address

  • NSAP in IS-IS is similar to router ID in OSPF
  • LSP uses NSAP address to identify router and establish topology table, so NSAP address is required to provide routing for IP
  • NSAP address is 8-20 bytes, identified by hexadecimal, and contains the following main information:
    • 1. Area number
    • 2. System number (fixed 6 bytes)
    • 3.NSEL bit (fixed 1 byte and reset to 0)
  • For example: 49.0001.0020.0200.2002.00
    • Analysis: 49.0001:49 is a fixed format. 0001 represents area 1. If the area is 30, it is 49.0030
    • 0020.0200.2002: converted from IP address 2.2.2.2
    • 00: fixed format
1.4.1: NSAP address conversion
  • Principle:
    • It is obtained by completing the 32-bit address of the loopback into 48 bits, that is, 3 bits are supplemented, and then 4 bits are divided
  • Example: 12.12.12.12
    • Make up 3 places: 012.012.012.012
    • 4-bit segmentation: 0120.1201.2012
  • So 12.12.12.12 is converted to 49.0001.0120.1201.2012.00

1.5: Huawei IS-IS common command

  • View command

  • dis isis peer  	 	'//View isis neighborhood '
    dis isis 1 brief    		'//View details of isis interface '
    dis isis interface g0/0/1	'//View interface isis details'
    
  • Configuration command

  • [Huawei]  isis 1   '//isis is followed by a process. The default is 1 process "
    [Huawei-isis-1]  network-entity 49.0001.0010.0100.1001.00  '//Make up three digits, then split four digits'
    [Huawei-isis-1]  is-level level-1    	'//Configure IS-IS routing type according to the network structure. There are router types here
    [Huawei-isis-1]  int g0/0/1             	'//Access interface '
    [Huawei-g0/0/1] isis enable		'//Start ISIS'
    
  • Route redistribution

  • isis 1
    import-route   rip 1 lever-1   		'//Change to L1 information default value after import '
    
    rip 1
    import-route isis 1 cost 5 		'//The measure for rip is hops'
    
    isis 1
    import-route isis level-2 into level-1	'//Huawei manual is called route leakage. "
    
    
  • Routing summarization

    isis 1
    summary 202.0.0.0 255.255.254.0 level-1-2	'//ABR summary: inter domain routing summary '
    
    isis 1
    summary 203.0.0.0 255.255.254.0 level-1	'//ASBR summary: route summary between different protocols'
    

2: Experimental verification

2.1: Environmental preparation

  • eNSP software
  • 6 routers, IP address customization

2.2: experimental topology

2.3: experiment process (if you don't understand, you can chat with me privately, or comment and exchange)

2.3.1: R5 configuration
  • <huawei>sys
    [huawei]sysname R5
    [R5]isis 1
    [R5-isis-1] is-level level-1	'//Set router isis level to L1 '
    [R5-isis-1] network-entity 49.0002.0050.0500.5005.00	'//Announce IP address'
    [R5-isis-1] q
    [R5] interface GigabitEthernet0/0/0	'//Access interface '
    [R5-GigabitEthernet0/0/0]ip address 45.0.0.2 255.255.255.252	'//Add IP address'
    [R5-GigabitEthernet0/0/0]isis enable 1	'//Open isis'
    [R5-GigabitEthernet0/0/0]un sh	'//Save '
    [R5-GigabitEthernet0/0/0]q	'//Exit '
    [R5]interface LoopBack0
    [R5-LoopBack0] ip address 5.5.5.5 255.255.255.255
    [R5-LoopBack0] isis enable 1
    [R5-LoopBack0] q
    [R5]interface LoopBack1
    [R5-LoopBack1] ip address 202.0.0.1 255.255.255.0
    [R5-LoopBack1] isis enable 1
    [R5-LoopBack1] q
    [R5]interface LoopBack2
    [R5-LoopBack2] ip address 202.0.1.1 255.255.255.0
    [R5-LoopBack2] isis enable 1
    [R5-LoopBack2]q
    [R5]
    
2.3.2: R4 configuration
  • <huawei>sys
    [huawei]sysname R4
    [R4]isis 1
    [R4-isis-1] network-entity 49.0002.0040.0400.4004.00	'//Announce IP address'
    [R4-isis-1] q
    [R4]interface GigabitEthernet0/0/0
    [R4-GigabitEthernet0/0/0] ip address 45.0.0.1 255.255.255.252
    [R4-GigabitEthernet0/0/0] isis enable 1
    [R4-GigabitEthernet0/0/0] un sh
    [R4-GigabitEthernet0/0/0]interface GigabitEthernet0/0/1
    [R4-GigabitEthernet0/0/1] ip address 34.0.0.2 255.255.255.252
    [R4-GigabitEthernet0/0/1] isis enable 1
    [R4-GigabitEthernet0/0/1] un sh
    [R4-GigabitEthernet0/0/1]interface LoopBack0
    [R4-LoopBack0] ip address 4.4.4.4 255.255.255.255
    [R4-LoopBack0] isis enable 1
    
2.3.3: R3 configuration
  • '//The configuration method is the same as R5 and R4. I paste the configured interface information directly here. The just R4 and R5 can understand, and this can also understand. '
    #
    sysname R3
    
    #
    isis 1
     is-level level-2
     network-entity 49.0000.0030.0300.3003.00
    #
    
    #
    interface GigabitEthernet0/0/0
     ip address 23.0.0.2 255.255.255.252
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     ip address 34.0.0.1 255.255.255.252
     isis enable 1
    #
    
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     isis enable 1
    #
    
    
2.3.4: R2 configuration
  • '//The configuration method is the same as R5 and R4. I paste the configured interface information directly here. The just R4 and R5 can understand, and this can also understand. '
    #
    sysname R2
    #
    
    #
    isis 1
     network-entity 49.0001.0020.0200.2002.00
    #
    
    #
    interface GigabitEthernet0/0/0
     ip address 23.0.0.1 255.255.255.252
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     ip address 12.0.0.2 255.255.255.252
     isis enable 1
    #
    
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     isis enable 1
    #
    
2.3.5: R1 configuration
  • '//The configuration method is the same as R5 and R4. I paste the configured interface information directly here. The just R4 and R5 can understand, and this can also understand. '
    sysname R1
    #
    #
    isis 1
     is-level level-1
     network-entity 49.0001.0010.0100.1001.00
    #
    
    #
    interface GigabitEthernet0/0/0
     ip address 16.0.0.1 255.255.255.252
    #
    interface GigabitEthernet0/0/1
     ip address 12.0.0.1 255.255.255.252
     isis enable 1
    #
    
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     isis enable 1
    #
    rip 1	'//Enter rip process'
     undo summary	'//Close route summary '
     version 2	'//Select version 2 '
     network 16.0.0.0	'//Announce segment '
    #
    
    
2.3.6: R6 configuration
  • '//The configuration method is the same as R5 and R4. I paste the configured interface information directly here. The just R4 and R5 can understand, and this can also understand. '
    sysname R6
    #
    
    #
    interface GigabitEthernet0/0/0
     ip address 16.0.0.2 255.255.255.252
    #
    
    #
    interface LoopBack0
     ip address 6.6.6.6 255.255.255.255
    #
    interface LoopBack1
     ip address 203.0.0.1 255.255.255.0
    #
    interface LoopBack2
     ip address 203.0.1.1 255.255.255.0
    #
    rip 1
     undo summary
     version 2
     network 16.0.0.0
     network 6.0.0.0
     network 203.0.0.0
     network 203.0.1.0
    #
    

2.4: route redistribution configuration

  • [R1]rip 1
    [R1-rip-1]import-route isis 1 cost 5 	'//Inject rip into isis'
    [R1-rip-1]q
    [R1]isis 1
    [R1-isis-1]import-route rip 1 level-1	'//Inject isis into rip '
    
  • At this time, use R2 to view the route information, and find that the route in isis can learn the route table entry in rip

    [R2]dis ip routing-table
    ...Ellipsis content
    
  • However, at this time, it will be found that R1 and R6 cannot learn the routing network segments in isis, and R5 cannot learn the network segments outside the region. How to solve this problem?

    • Reason: because R1 is L1, he can only learn the route in the region, but not the isis route information in other regions

    • Solution: route leakage

      [R2]isis 1
      [R2-isis-1]import-route isis level-2 into level-1 '//Disclose isisL2 information to L1 information
      
    • At this time, check R1 and R5 again, and you will find that you have learned the routing entry

    • Similarly, on R4, route information is leaked to R5

    • [R4]isis 
      [R4-isis-1]import-route isis level-2 into level-1 
      

2.5: route summary configuration

  • We find that the two loopback addresses of R5 and R6 are in the same network segment. When using other routers to view the routing table, we can find that these loopback addresses are separate

  • [R2]dis ip routing-table
    ...Ellipsis content
          202.0.0.0/24  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          202.0.1.0/24  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          203.0.0.0/24  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet
    0/0/1
          203.0.1.0/24  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet
    0/0/1
    
  • We can summarize

  • '//R4 summarization
    [R4]isis 	
    [R4-isis-1]summary 202.0.0.0 255.255.254.0 level-1-2
    '//R1 summarization
    [R1]isis                           
    [R1-isis-1]summary 203.0.0.0 255.255.254.0 level-1
    
  • At this time, we use the route to view the IP address

  • [R2]dis ip routing-table
    ...Ellipsis content
          202.0.0.0/23  ISIS-L2 15   30          D   23.0.0.2        GigabitEthernet
    0/0/0
          203.0.0.0/23  ISIS-L1 15   74          D   12.0.0.1        GigabitEthernet
    0/0/1
    
  • End of experiment

105 original articles published, 60 praised, 10000 visitors+
Private letter follow

Tags: network

Posted on Wed, 05 Feb 2020 04:04:54 -0800 by jonabomer