Error in compiling and installing httpd-2.4.29 in CentOS 6

[root@centos6 httpd-2.4.29]#./configure --prefix=/app/httpd24 \
--enable-so \
--enable-ssl \
--enable-cgi \
--enable-rewrite \
--with-zlib \
--with-pcre \
--with-apr=/app/apr/ \
--with-apr-util=/app/apr-util/ \
--enable-modules=most \
--enable-mpms-shared=all \
--with-mpm=prefork

[root@centos6 httpd-2.4.29]#Make & & make install / / this step is an error
//The installation path has been specified, or there is an error.
/usr/local/apr-util/lib/libaprutil-1.so: undefined reference to `XML_GetErrorCode'
/usr/local/apr-util/lib/libaprutil-1.so: undefined reference to `XML_SetEntityDeclHandler'
/usr/local/apr-util/lib/libaprutil-1.so: undefined reference to `XML_ParserCreate'
/usr/local/apr-util/lib/libaprutil-1.so: undefined reference to `XML_SetCharacterDataHandler'
/usr/local/apr-util/lib/libaprutil-1.so: undefined reference to `XML_ParserFree'
/usr/local/apr-util/lib/libaprutil-1.so: undefined reference to `XML_SetUserData'
/usr/local/apr-util/lib/libaprutil-1.so: undefined reference to `XML_StopParser'
/usr/local/apr-util/lib/libaprutil-1.so: undefined reference to `XML_Parse'
/usr/local/apr-util/lib/libaprutil-1.so: undefined reference to `XML_ErrorString'
/usr/local/apr-util/lib/libaprutil-1.so: undefined reference to `XML_SetElementHandler'
collect2: error: ld returned 1 exit status
make[2]: *** [htpasswd] Error 1
make[2]: Leaving directory `/usr/local/httpd-2.4.26/support'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/httpd-2.4.26/support'
make: *** [all-recursive] Error 1

Every time you install it, there are different problems. I thought it was a small question, but I searched it for a long time and didn't find the answer.

terms of settlement:

Online search
    It turns out that APR APR util uses the latest version 1.6 (there is no problem in the previous version 1.6 compiling and installing apache in centos7)
    The version has been reduced. Use version 1.5 to solve the problem.
Solved by myself
    Recompile (no problem with previous installation, it should not be the problem above. So recompile)
    The important thing is that recompilation is successful

I don't know what the problem is, so I have to recompile
But I hope to leave comments and exchanges
Finally, good luck

Tags: SSL zlib Apache

Posted on Wed, 29 Apr 2020 23:58:33 -0700 by oc1000